+7 495 955-25-82+7 499 990-10-21

Кому нужен План обмена 1С УТ и Дэнси on-line?

Re: Кому нужен План обмена 1С УТ и Дэнси on-line?

Сообщение Caml » 18 июл 2013, 16:56

Добрый день. Может что не правильно делаю? УТ 10.3 (10.3.21.1) Когда выбираю главный узел ругается: В качестве узла обмена выбран узел, соответствующий текущей информационной базе.Эти изменения сделал:
1. =========================================================
ВыпонитьДействияПерелНачаломОбменаДанными
"/////////////////////////////////////
//Обмен ДЭНСИ меняется сам с собой)//
//надо бы узнать не он ли это)) //
/////////////////////////////////////
Если МетаданныеУзлаОбмена.Имя = "ОбменСDЭНСИ" Тогда
ПланыОбмена.ОбменСDЭНСИ.ЭтотУзел().ПолучитьОбъект().Поехали();
КонецЕсли;
Если (СтруктураНастроекОбменаДанными.ДанныеНастройки.УзелИнформационнойБазы = СтруктураНастроекОбменаДанными.ТекущийУзелПланаОбмена)
и (МетаданныеУзлаОбмена.Имя <> "ОбменСDЭНСИ") Тогда
"
===========================================
2. ========================================
план обмена ОбменСDЭНСИ
===========================================
Caml
 
Постов: 3
Зарегистрирован: 10 июл 2013, 09:35
Откуда: Астрахань

Re: Кому нужен План обмена 1С УТ и Дэнси on-line?

Сообщение kedr19 » 24 июл 2013, 08:12

Этого куска кода уже нет у меня, давно переделал.

Сейчас при обходе узлов делаю так:
Код: Выделить всё
ВыборкаУзлов = ПланОбмена.ОбменСDЭНСИ.Выбрать()
Пока ВыборкаУзловюСледующий() Цикл
Если ВыборкаУзлов.Наименование = Строка(ПланОбмена.ОбменаСDЭНСИ.ЭтотУзел()) Тогда
Продолжить
Иначе
.............
КонецЦикла


PS
для проверки состояния кассы вкл/выкл, перед всеми опреациями с ней делаю простой Ping к ней. в коде узла Плана обмена забиты их IP адреса.
Код: Выделить всё
   Попытка
      ServicesSet = GetCOMObject("winmgmts:{impersonationLevel=impersonate}");
      Переменные = ServicesSet.ExecQuery("SELECT StatusCode FROM Win32_PingStatus WHERE address = '" + IP + "' AND Timeout=10");
   Исключение   
      Возврат Неопределено ;
   КонецПопытки;
   Для Каждого Переменная Из Переменные Цикл
      Если Переменная.StatusCode = 0 Тогда
         Возврат Истина;
      Иначе
         Возврат Ложь;
      КонецЕсли;
   КонецЦикла;

раньше использовал функцию 1с проверить каталог, но она работает раз в 10 медленнее
kedr19
 
Постов: 586
Зарегистрирован: 24 окт 2011, 15:49
Откуда: г. Новосибирск

Re: Кому нужен План обмена 1С УТ и Дэнси on-line?

Сообщение Kuzmich » 19 авг 2013, 12:04

Выложите пожалуйста обновленную cf-ку.
Kuzmich
 
Постов: 1
Зарегистрирован: 16 авг 2013, 10:09

Re: Кому нужен План обмена 1С УТ и Дэнси on-line?

Сообщение kedr19 » 19 авг 2013, 12:59

Kuzmich писал(а):Выложите пожалуйста обновленную cf-ку.


с выкладыванием у меня проблемы какие то(( почту напиши в личку вышлю
kedr19
 
Постов: 586
Зарегистрирован: 24 окт 2011, 15:49
Откуда: г. Новосибирск

Re: Кому нужен План обмена 1С УТ и Дэнси on-line?

Сообщение john-s » 13 апр 2016, 11:48

Здравствуйте, поделитесь пожалуйста планом обмена 1С и Денси online.
3717641@mail.ru
Спасибо!
john-s
 
Постов: 6
Зарегистрирован: 13 апр 2016, 11:42

Re: Кому нужен План обмена 1С УТ и Дэнси on-line?

Сообщение kedr19 » 14 апр 2016, 08:21

on-line был сильно видоизменен до самописной конфигурации под конкретные задачи.
Могу скинуть только процедуры вывода и загрузки, на их базе сможете сделать что вам нужно.
kedr19
 
Постов: 586
Зарегистрирован: 24 окт 2011, 15:49
Откуда: г. Новосибирск

Re: Кому нужен План обмена 1С УТ и Дэнси on-line?

Сообщение john-s » 14 апр 2016, 13:50

kedr19 писал(а):on-line был сильно видоизменен до самописной конфигурации под конкретные задачи.
Могу скинуть только процедуры вывода и загрузки, на их базе сможете сделать что вам нужно.


Скиньте пожалуйста. Буду признателен за любую помощь! Огромное спасибо!
john-s
 
Постов: 6
Зарегистрирован: 13 апр 2016, 11:42

Re: Кому нужен План обмена 1С УТ и Дэнси on-line?

Сообщение kedr19 » 26 апр 2016, 15:54

Скидываю общий подход с текстами. Кому нужно тот пусть просто заменит на свои данные.

Что не понятно пишите.

В файле "выгрузка" текст общего модуля "ФормированиеФайлаВыгрузки"
"вызов выгрузки" процедура где вызывается формирование файла.
(СерверКассыККМ) = узел из плана обмена.
"ЗагрузкаЧеков" - текст одноименного общего модуля модуля
"ТекстыЗапросовДэнси" - текст одноименного общего модуля модуля
https://yadi.sk/d/BZM6SMm1rJMmS

P.S. С файла загрузка есть. если кому нужна в таком же виде тоже скину.
kedr19
 
Постов: 586
Зарегистрирован: 24 окт 2011, 15:49
Откуда: г. Новосибирск

Re: Кому нужен План обмена 1С УТ и Дэнси on-line?

Сообщение kuman » 29 апр 2017, 21:29

Не смог разобраться с главным узлом - может есть мануал по настройке?
Кто у себя реализовал, помогите разобраться как настроить онлайн обмен?
После обновления появился план обмена с Дэнси, не могу настроить. Может у кого есть уже настроенная конфа для образца? Поделитесь на sumarokov.78@mail.ru
Ubuntu 12.04 32 bit. ДК 1.3.1 patch2_426
kuman
 
Постов: 474
Зарегистрирован: 18 апр 2011, 20:28

Re: Кому нужен План обмена 1С УТ и Дэнси on-line?

Сообщение nnaavv » 07 июл 2017, 11:17

Скинте пожалуйста загрузку с файла
nnaavv
 
Постов: 6
Зарегистрирован: 07 июл 2017, 11:12

Пред.

Вернуться в Интеграция с различным товароучетным ПО

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1


cron

Кто сейчас на конференции

Сейчас посетителей на конференции: 1, из них зарегистрированных: 0, скрытых: 0 и гостей: 1 (основано на активности пользователей за последние 5 минут)
Больше всего посетителей (68) здесь было 14 ноя 2017, 18:26

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1